Commit d608776f authored by Zen Fu's avatar Zen Fu
Browse files

[weblate] lint (tails#17377)

parent 99abeace
......@@ -32,14 +32,14 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'celery':
version => '4.4.4', # >=4.0
tag => 'v4.4.4',
tag => 'v4.4.4',
url => 'https://github.com/celery/celery',
require => [Exec['pip_install_billiard'], Exec['pip_install_kombu'], Exec['pip_install_vine'], Exec['pip_install_redis']],
}
tails::pip_package_from_repo { 'celery-batches':
version => '0.3', # >=0.2
tag => 'v0.3',
tag => 'v0.3',
url => 'https://github.com/percipient/celery-batches',
require => [Exec['pip_install_celery']],
}
......@@ -52,7 +52,7 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'django-appconf':
version => '1.0.4', # >=1.0
tag => 'v1.0.4',
tag => 'v1.0.4',
url => 'https://github.com/django-compressor/django-appconf',
require => [Exec['pip_install_django']],
}
......@@ -76,7 +76,7 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'filelock':
version => '3.0.12', # >=3.0.1
tag => 'v3.0.12',
tag => 'v3.0.12',
url => 'https://github.com/benediktschmitt/py-filelock',
}
......@@ -93,26 +93,26 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'kombu':
version => '4.6.10', # >=4.6.10,<4.7
tag => 'v4.6.10',
tag => 'v4.6.10',
url => 'http://github.com/celery/kombu',
require => [Exec['pip_install_amqp'], Exec['pip_install_importlib-metadata'], Exec['pip_install_redis']],
}
tails::pip_package_from_repo { 'oauthlib':
version => '3.1.0', # >=3.0.0
tag => 'v3.1.0',
tag => 'v3.1.0',
url => 'https://github.com/oauthlib/oauthlib',
}
tails::pip_package_from_repo { 'openpyxl':
version => '2.6.4', # >=2.5.0
url => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
version => '2.6.4', # >=2.5.0
url => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
repo_type => 'hg',
}
tails::pip_package_from_repo { 'python3-openid':
version => '3.1.0', # >=3.0.10
tag => 'v3.1.0',
tag => 'v3.1.0',
url => 'http://github.com/necaris/python3-openid',
}
......@@ -128,7 +128,7 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'siphashc':
version => '1.3', # >=0.8
tag => 'v1.3',
tag => 'v1.3',
url => 'https://github.com/WeblateOrg/siphashc',
}
......@@ -167,13 +167,13 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'vine':
version => '1.3.0', # ==1.3.0
tag => 'v1.3.0',
tag => 'v1.3.0',
url => 'http://github.com/celery/vine',
}
tails::pip_package_from_repo { 'zipp':
version => '3.1.0', # >=0.5
tag => 'v3.1.0',
tag => 'v3.1.0',
url => 'https://github.com/jaraco/zipp',
}
......
......@@ -221,7 +221,7 @@ class Dependency:
lines.append(f"version => '{self.newest_pip_version}',")
if self.tag:
lines.append(f"tag => '{self.tag}',")
lines.append(f"tag => '{self.tag}',")
lines.append(f"url => '{self.url}',")
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment