Commit 99abeace authored by Zen Fu's avatar Zen Fu
Browse files

[weblate] Pin version of openpyxl (tails#17377)

The deps update script does not correctly check for compatibility with
Python for direct dependencies of Weblate (such check is only done for
dependencies of dependencies).

Therefore, we manually pin openpyxl version to <3.0 as bigger versions
all depend on Python >= 3.6 which is not available in Debian Stretch.
parent 202229ec
......@@ -105,7 +105,7 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'openpyxl':
version => '3.0.3', # >=2.5.0
version => '2.6.4', # >=2.5.0
url => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
repo_type => 'hg',
}
......
......@@ -44,6 +44,8 @@ pip:
openpyxl:
url: https://bitbucket.org/openpyxl/openpyxl/src/default
repo_type: hg
additional_condition:
- <3.0 # Bigger versions require Python >=3.6
rjsmin:
url: https://github.com/ndparker/rjsmin
translate-toolkit:
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment