Upgrade po4a to the version in Bullseye

Rationale: we want to have po4a from Bullseye available and pinned once we upgrade to Bookworm.

Refs: tails#18667 (closed)

Merge request reports