Commit 096755c1 authored by Zen Fu's avatar Zen Fu
Browse files

[weblate] Update Celery to 4.4.5

parent 677867e4
......@@ -31,10 +31,10 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'celery':
version => '4.4.4', # >=4.0
tag => 'v4.4.4',
version => '4.4.5', # >=4.0
tag => 'v4.4.5',
url => 'https://github.com/celery/celery',
require => [Exec['pip_install_billiard'], Exec['pip_install_kombu'], Exec['pip_install_vine'], Exec['pip_install_redis']],
require => [Exec['pip_install_billiard'], Exec['pip_install_future'], Exec['pip_install_kombu'], Exec['pip_install_vine'], Exec['pip_install_redis']],
}
tails::pip_package_from_repo { 'celery-batches':
......@@ -80,6 +80,11 @@ class tails::weblate::python_modules () {
url => 'https://github.com/benediktschmitt/py-filelock',
}
tails::pip_package_from_repo { 'future':
version => '0.18.2', # >=0.18.0
url => 'https://python-future.org',
}
tails::pip_package_from_repo { 'importlib-metadata':
version => '1.6.1', # >=0.18
tag => 'v1.6.1',
......@@ -106,8 +111,8 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'openpyxl':
version => '2.6.4', # >=2.5.0
url => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
version => '2.6.4', # >=2.5.0,<3.0
url => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
repo_type => 'hg',
}
......@@ -161,7 +166,8 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'user-agents':
version => 'v2.1.0', # >=1.1.0
version => '2.1', # >=1.1.0
tag => 'v2.1.0',
url => 'https://github.com/selwin/python-user-agents',
require => [Exec['pip_install_ua-parser']],
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment