1. 09 Oct, 2019 3 commits
  2. 08 Oct, 2019 8 commits
  3. 07 Oct, 2019 4 commits
  4. 06 Oct, 2019 5 commits
    • segfault's avatar
      Don't set browser.uiCustomization.state twice in Unsafe Browser prefs (refs: #17055) · bd8319f3
      segfault authored
      This is a fixup against 05acf4b8, which
      sets the browser.uiCustomization.state in
      config/chroot_local-includes/usr/share/tails/chroot-browsers/unsafe-browser/prefs.js,
      but we already write that pref to that file during build time in
      apply_prefs_hacks() in config/chroot_local-hooks/10-tbb.
      bd8319f3
    • segfault's avatar
    • intrigeri's avatar
      Test suite: re-add French-specific reference image for the Unsafe Browser start page. · 7eac43ba
      intrigeri authored
      This localized picture was previously removed by
      commit:396b0ead.
      
      The string we're looking for is now translated into French, so we need to
      reintroduce a locale-specific reference image. Otherwise, when French is picked
      by supported_torbrowser_languages.sample(3), the "Unsafe Browser can be used in
      all languages supported in Tails" scenario will fail with "Unsafe Browser failed
      to launch in the following locale(s): fr_FR.utf8".
      7eac43ba
    • intrigeri's avatar
      Merge branch 'feature/16664-simplify-tor-has-bootstrapped+force-all-tests'... · 34e4e3f2
      intrigeri authored
      Merge branch 'feature/16664-simplify-tor-has-bootstrapped+force-all-tests' into devel (Closes: #16664)
      34e4e3f2
    • intrigeri's avatar
      Unlock VeraCrypt Volumes: fix required GLib version. · 78f7e163
      intrigeri authored
      Fixup against 85e9ffd6.
      
      Otherwise, Unlock VeraCrypt Volumes fails to start with:
      
       Traceback (most recent call last):
         File "/usr/local/bin/unlock-veracrypt-volumes", line 15, in <module>
           from unlock_veracrypt_volumes.volume_manager import VolumeManager
         File "/usr/lib/python3/dist-packages/unlock_veracrypt_volumes/volume_manager.py", line 11, in <module>
           from unlock_veracrypt_volumes.volume_list import ContainerList, DeviceList
         File "/usr/lib/python3/dist-packages/unlock_veracrypt_volumes/volume_list.py", line 8, in <module>
           from unlock_veracrypt_volumes.volume import Volume
         File "/usr/lib/python3/dist-packages/unlock_veracrypt_volumes/volume.py", line 11, in <module>
           gi.require_version('GLib', '3.0')
         File "/usr/lib/python3/dist-packages/gi/__init__.py", line 121, in require_version
           (namespace, loaded_version))
       ValueError: Namespace GLib is already loaded with version 2.0
      
      And regardless, GObject Introspection data for GLib is currently 2.0,
      so I'm pretty sure that requiring 3.0 can't work anyway.
      78f7e163
  5. 05 Oct, 2019 14 commits
  6. 04 Oct, 2019 6 commits