1. 19 Feb, 2018 1 commit
  2. 06 Jan, 2018 1 commit
  3. 04 Jan, 2018 1 commit
  4. 02 Jan, 2018 1 commit
  5. 16 Dec, 2017 1 commit
  6. 10 Nov, 2017 1 commit
  7. 09 Nov, 2017 1 commit
  8. 08 Nov, 2017 1 commit
  9. 05 Oct, 2017 1 commit
  10. 15 Sep, 2017 1 commit
  11. 14 Aug, 2017 2 commits
  12. 22 May, 2017 1 commit
  13. 18 May, 2017 1 commit
  14. 17 Apr, 2017 2 commits
  15. 15 Mar, 2017 1 commit
  16. 14 Mar, 2017 1 commit
  17. 08 Mar, 2017 1 commit
  18. 02 Mar, 2017 3 commits
  19. 28 Feb, 2017 1 commit
    • anonym's avatar
      Completely remove I2P. · e9d02049
      anonym authored
      We have decided to remove I2P (Refs: #11276) due to our failure of
      finding someone interested in maintaining it in Tails.
      
      Will-fix: #12263
      e9d02049
  20. 30 Jan, 2017 1 commit
  21. 27 Dec, 2016 1 commit
  22. 20 Dec, 2016 1 commit
  23. 19 Dec, 2016 1 commit
  24. 06 Dec, 2016 1 commit
  25. 20 Nov, 2016 1 commit
  26. 15 Nov, 2016 1 commit
  27. 07 Nov, 2016 1 commit
  28. 03 Nov, 2016 1 commit
  29. 30 Oct, 2016 1 commit
  30. 21 Sep, 2016 1 commit
  31. 20 Sep, 2016 1 commit
    • anonym's avatar
      Revert "Install Linux 4.7." · e4c35183
      anonym authored
      This reverts commits:
      
      * ab562fd4
      * c0bc655c
      * 80d0667a
      
      The last minute attempt to include it in Tails 2.6 was a bad (too hasty)
      idea, e.g. USB installations don't boot (pre-init results in
      "FAT-fs (sdb1): IO charset ascii not found"). Also it seems that the
      backport of Linux 4.7 hasn't gone through the proper Debian QA process.
      e4c35183
  32. 19 Sep, 2016 1 commit
    • anonym's avatar
      Install Linux 4.7. · ab562fd4
      anonym authored
      While preparing Tails 2.6 it was discovered that our previous last
      minute bump of the 'debian' snapshot (to get Jessie 8.6) caused
      linux-compiler-gcc-4.9-x86 to be updated to a version from another Linux
      source version (4.7) than what we planned to install (4.6), resulting in
      the tagged snapshot being impossible to create since it would require
      two different linux source packages which we do not support.
      
      Note that this includes bumping the aufs4-standalone Git submodule to
      the latest branch for Linux 4.7.
      ab562fd4
  33. 14 Jul, 2016 1 commit
  34. 09 Jun, 2016 1 commit
  35. 08 Jun, 2016 1 commit
  36. 07 Jun, 2016 1 commit
    • intrigeri's avatar
      Upgrade to Linux 4.5. · 4eb604e7
      intrigeri authored
      This is essentially a squashed version of feature/8415-overlayfs, purged
      of its overlayfs-specific bits, and that fetches the kernel from
      jessie-backports (instead of from sid) to ease compiling out-of-tree and
      dkms modules. At this stage, the resulting ISO won't boot since it'll
      lack both aufs and overlayfs.
      
      refs: #10298
      
      To achieve that:
      
      * Install the 686 kernel flavour instead of the obsolete 586 one.
      
      * Rename the amd64 kernel via binary_local-hooks.
      
        lb_binary_syslinux depends on --linux-flavours, but we can't pass
        amd64 in there anymore (due to lack of multiarch support) so we need
        to rename the second (amd64) kernel ourselves.
      
      * APT, dpkg: add amd64 architecture. The amd64 kernel flavour is not
        built anymore for the i386 architecture, so we need to use
        multiarch now.
      
      * Temporary disable dkms modules building.
      
        Building them for the amd64 kernel requires installing an amd64
        toolchain, that conflicts with the i386 one and with lots of packages
        we need. Let's come back to it later (refs: #9969).
      4eb604e7