Commit 7b7c8d8f authored by intrigeri's avatar intrigeri

Add a sanity check to warn developers if they use the unsupported a= in APT pinning.

parent 984e8543
......@@ -16,6 +16,13 @@ fi
export LB_BOOTSTRAP_INCLUDE='eatmydata'
# sanity checks
if grep -qs -E '^Pin:\s+release\s+.*a=' config/chroot_apt/preferences ; then
echo "Found unsupported n= syntax in config/chroot_apt/preferences,"
echo "use n= instead. Exiting."
exit 1
fi
# init variables
RUN_LB_CONFIG="lb config noauto"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment