Commit 541cd407 authored by Ulrike Uhlig's avatar Ulrike Uhlig
Browse files

Replace all occurrences of apt-get by apt

where this is logical and useful. Don't do it in past news or things talking about Squeeze, nor infrastructural bits.
parent 9ec5885c
......@@ -169,11 +169,11 @@ Crea e configura la partizione resistente attivando le seguenti funzionalità (A
Aggiorna la lista dei pacchetti disponibili, scrivendo in un terminale:
sudo apt-get update
sudo apt update
Installa i seguenti pacchetti:
sudo apt-get install libyaml-perl libyaml-libyaml-perl po4a \
sudo apt install libyaml-perl libyaml-libyaml-perl po4a \
perlmagick libyaml-syck-perl ikiwiki
Clona il nostro repository Git in una cartella della partizione persistente:
......
......@@ -7,7 +7,7 @@
This is currently easiest to set up (to avoid backporting, see below)
on a Debian Sid box with libvirt installed:
sudo apt-get install vagrant
sudo apt install vagrant
vagrant plugin install vagrant-libvirt
After this, the Tails branch `feature/vagrant-libvirt` makes
......@@ -149,10 +149,10 @@ might just as well update the system and take steps to reduce the
image size:
unset HISTFILE
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install rsync
sudo apt-get remove virtualbox*
sudo apt update
sudo apt upgrade
sudo apt install rsync
sudo apt remove virtualbox*
sudo apt-get autoremove
sudo apt-get clean
sudo rm -rf /var/lib/apt/lists/*
......
......@@ -43,7 +43,7 @@ According to [a blog
post](http://blog.rupamsunyata.org/2008/06/30/consolation-prize.xhtml),
`certutil` may be an adequate tool for the task:
apt-get install libnss3-tools
apt install libnss3-tools
certutil -d $HOME/.mozilla/firefox/$HLAGHLLAGHGAAHLGALHHGHLAGH.default -A -n 'CA Cert Signing Authority - Root CA' -t CT,C,C -i /etc/ssl/certs/root.pem
What does not work is to disable this module for the no-CAs profile
......
......@@ -53,11 +53,11 @@ Debian Stretch, and one of Tails' repos until [[!debbug 823395]] is fixed:
deb-src http://deb.tails.boum.org/ builder-jessie main
EOF
sudo apt-get update
sudo apt update
Now we can install all the dependencies:
sudo apt-get install \
sudo apt install \
git \
rake \
libvirt-daemon-system \
......@@ -343,7 +343,7 @@ The following Debian packages need to be installed:
Then install these dependencies from Jessie:
apt-get install \
apt install \
dpkg-dev \
gettext \
intltool \
......@@ -362,7 +362,7 @@ The following Debian packages need to be installed:
manually that the following command actually does install the
expected versions):
apt-get install \
apt install \
debootstrap/jessie-backports \
ikiwiki/jessie-backports
......
......@@ -51,7 +51,7 @@ Installing the requirements
Debian packages:
sudo apt-get install vmdebootstrap vagrant-libvirt
sudo apt install vmdebootstrap vagrant-libvirt
Generating a new base box
-------------------------
......
......@@ -17,11 +17,11 @@ Build the website in Linux
1. Update the list of available packages:
sudo apt-get update
sudo apt update
2. Install the required packages:
sudo apt-get install libyaml-perl libyaml-libyaml-perl po4a \
sudo apt install libyaml-perl libyaml-libyaml-perl po4a \
perlmagick libyaml-syck-perl ikiwiki
You need to install ikiwiki version 3.20170111~bpo8+1 or newer.
......@@ -60,11 +60,11 @@ Build the website in Tails
3. Update the list of available packages:
sudo apt-get update
sudo apt update
4. Install the required packages:
sudo apt-get install libyaml-perl libyaml-libyaml-perl po4a \
sudo apt install libyaml-perl libyaml-libyaml-perl po4a \
perlmagick libyaml-syck-perl ikiwiki/jessie-backports
5. Clone our main [[Git repository|git]] in the <span class="filename">Persistent</span> folder:
......
......@@ -350,7 +350,7 @@ First, those additional software packages are installed offline from tails-greet
`PostLogin` script.
Then, once connected to the network, a NetworkManager dispatcher hook looks for
upgrades if additional software were activated (`apt-get update`, then `apt-get
upgrades if additional software were activated (`apt update`, then `apt
install` the additional software packages). For some packages (e.g. already
running software) the change will only be effective at next boot but hopefully a outdated
version won't be used too long in the meantime.
......
......@@ -9,9 +9,9 @@ Below we define some terms that are used in a somewhat or 100% special
meaning within the Tails community.
For other terms, use [The Jargon Lexicon](http://catb.org/jargon/)
(`apt-get install dict-jargon`),
(`apt install dict-jargon`),
[V.E.R.A.](http://home.snafu.de/ohei/vera/vera-e.html)
(`apt-get install dict-vera`), the
(`apt install dict-vera`), the
[Wiktionary](https://en.wiktionary.org/) and
[Wikipedia](https://en.wikipedia.org/).
......
......@@ -69,8 +69,8 @@ to style your documentation using CSS.
- Code: `<span class="code">id="tails-greeter"</span>`
- Result: <span class="code">id="tails-greeter"</span>
- <span class="code">span.command</span> for command names
- Code: `the <span class="command">apt-get</span> command`
- Result: the <span class="command">apt-get</span> command
- Code: `the <span class="command">apt</span> command`
- Result: the <span class="command">apt</span> command
- <span class="code">span.filename</span> for file names, for example:
- Code: `the <span class="filename">~/.gnupg/gpg.conf</span> file`
- Result: the <span class="filename">~/.gnupg/gpg.conf</span> file
......
......@@ -38,16 +38,16 @@ To install additional software packages:
3. Execute the following command to update the lists of available packages:
apt-get update
apt update
3. To install an additional package, execute the following command, replacing
`[package]` with the name of the package that you want to install:
apt-get install [package]
apt install [package]
For example, to install the package `ikiwiki`, execute:
apt-get install ikiwiki
apt install ikiwiki
<div class="note">
......
......@@ -18,7 +18,7 @@ Installation
To install *GNOME Boxes* in Debian or Ubuntu, execute the following
command:
sudo apt-get install gnome-boxes
sudo apt install gnome-boxes
Running Tails from an ISO image
===============================
......
......@@ -51,12 +51,12 @@ Installation
To install *virt-manager* in Debian, execute the following
command:
sudo apt-get install virt-manager libvirt-daemon-system
sudo apt install virt-manager libvirt-daemon-system
To install *virt-manager* in Ubuntu, execute the following
command:
sudo apt-get install virt-manager libvirt-bin qemu-kvm
sudo apt install virt-manager libvirt-bin qemu-kvm
Running Tails from an ISO image
===============================
......
......@@ -52,7 +52,7 @@ Installation
To install *VirtualBox* in Debian or Ubuntu, execute the following
command:
sudo apt-get install virtualbox
sudo apt install virtualbox
For instructions on how to install *VirtualBox* on other operating
systems, refer to the [VirtualBox documentation](https://www.virtualbox.org/wiki/End-user_documentation).
......
......@@ -251,7 +251,7 @@ persistent volume.
When this feature is activated, the packages that you install using the
<span class="application">Synaptic</span> package manager or the
<span class="command">apt-get</span> command are saved in the persistent volume.
<span class="command">apt</span> command are saved in the persistent volume.
If you
[[install additional programs|doc/advanced_topics/additional_software]],
......@@ -279,7 +279,7 @@ Those so called <span class="emphasis">APT lists</span> correspond to the files
downloaded while doing
<span class="guilabel">Reload</span> from the
<span class="application">Synaptic</span> package manager or issuing the
<span class="command">apt-get update</span> command.
<span class="command">aptupdate</span> command.
The <span class="emphasis">APT lists</span> are needed to
[[install additional programs|doc/advanced_topics/additional_software]]
......
......@@ -45,7 +45,7 @@ Trust|install/download/openpgp#wot]].
1. Install the Debian keyring. It contains the OpenPGP keys of all Debian developers:
sudo apt-get install debian-keyring
sudo apt install debian-keyring
1. Import the OpenPGP key of [[!wikipedia Stefano_Zacchiroli]], a former
Debian Project Leader, from the Debian keyring into your keyring:
......
......@@ -24,7 +24,7 @@ To upgrade Tor, start a *Root Terminal* from the
*Applications* → *Accessories* menu, and type the following command in
there:
apt-get update && apt-get install tor && service tor start
apt update && apt install tor && service tor start
... then type *Enter*, and wait until the upgrade is completed, which
may take a few minutes. At this time, the Vidalia icon on the top
......
......@@ -166,12 +166,12 @@ that does *not* behave like Tails should. Follow the
<a id="upgrade"></a>
Should I update Tails using `apt-get` or <span class="application">Synaptic</span>?
Should I update Tails using `apt` or <span class="application">Synaptic</span>?
-----------------------------------------------------------------------------------
No. Tails provides upgrades every six weeks, that are thoroughly tested
to make sure that no security feature or configuration gets broken.
If you upgrade the system yourself using `apt-get` or <span class="application">Synaptic</span>,
If you upgrade the system yourself using `apt` or <span class="application">Synaptic</span>,
you might break things. Upgrading when you get a notification from
<span class="application">[[Tails Upgrader|doc/first_steps/upgrade]]</span> is enough.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment