Commit 419981ac authored by intrigeri's avatar intrigeri
Browse files

Changelog: finish adding and formatting info about the current state of the code.

parent d9e9a501
tails (2.0~beta1) UNRELEASED; urgency=medium tails (2.0~beta1) UNRELEASED; urgency=medium
XXX: see changelog of custom packages
* Major new features and changes * Major new features and changes
- Upgrade to Debian 8 (Jessie). - Upgrade to Debian 8 (Jessie).
- Migrate to GNOME Shell in Classic mode. - Migrate to GNOME Shell in Classic mode.
...@@ -28,12 +26,32 @@ tails (2.0~beta1) UNRELEASED; urgency=medium ...@@ -28,12 +26,32 @@ tails (2.0~beta1) UNRELEASED; urgency=medium
* Minor improvements * Minor improvements
- Remove obsolete code from various places. - Remove obsolete code from various places.
- Use socket activation for CUPS, to save some boot time. - Tails Greeter:
- Port XXX [check custom packages] to GTK3 / UDisks2 / Python 3 / whatever. · hide all windows while logging in
· resize and re-position the panel when the screen size grows
· PostLogin: log into the Journal instead of a dedicated log file
· use localectl to set the system locale and keyboard mapping
· delete the Live user's password if no administration password is set
(Closes: #5589)
· port to GDBus greeter interface, and adjust to other GDM
and GNOME changes
- Tails Installer:
· port to UDisks2, and from Qt4 to GTK3
· adapt to work on other GNU/Linux operating systems than Tails
· clean up enough upstream code and packaging bits to make it
deserve being uploaded to Debian
· rename everything from liveusb-creator to tails-installer
- Port tails-perl5lib to GTK3 and UDisks2. In passing, do some minor
refactoring and a GUI improvement.
- Persistent Volume Assistant:
· port to GTK3 and UDisks2
· handle errors when deleting persistent volume (Closes: #8435)
· remove obsolete workarounds
- Don't install UDisks v1. - Don't install UDisks v1.
- Adapt custom udev and polkit rules to UDisks v2 (Closes: #9054, #9270). - Adapt custom udev and polkit rules to UDisks v2 (Closes: #9054, #9270).
- Adjust import-translations' post-import step for Tails Installer, - Adjust import-translations' post-import step for Tails Installer,
to match how its i18n system works nowadays. to match how its i18n system works nowadays.
- Use socket activation for CUPS, to save some boot time.
- Set memlockd.service's OOMScoreAdjust to -1000. - Set memlockd.service's OOMScoreAdjust to -1000.
- Don't bother creating /var/lib/live in tails-detect-virtualization. - Don't bother creating /var/lib/live in tails-detect-virtualization.
If it does not exist at this point, we have bigger and more If it does not exist at this point, we have bigger and more
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment