Commit 18d1d738 authored by sajolida's avatar sajolida
Browse files

List upgrade before install (#16470)

It's probably less dangerous and confusing to show upgrade first to
people who want to install than to show install first to people who want
to upgrade as they could erase their persistence is their follow the
installation instructions
parent 3ccb1132
......@@ -65,16 +65,6 @@ See the list of [[long-standing issues|support/known_issues]].
# Get Tails $VERSION
## To install Tails on a new USB stick
Follow our installation instructions:
- [[Install from Windows|install/win]]
- [[Install from macOS|install/mac]]
- [[Install from Linux|install/linux]]
<div class="caution"><p>All the data on this USB stick will be lost.</p></div>
## To upgrade your Tails USB stick and keep your persistent storage
- Automatic upgrades are available from $VERSION-2, $VERSION-1, and $VERSION-1~rc1 to $VERSION.
......@@ -86,6 +76,16 @@ Follow our installation instructions:
- If you cannot do an automatic upgrade or if Tails fails to start after an
automatic upgrade, please try to do a [[manual upgrade|upgrade]].
## To install Tails on a new USB stick
Follow our installation instructions:
- [[Install from Windows|install/win]]
- [[Install from macOS|install/mac]]
- [[Install from Linux|install/linux]]
<div class="caution"><p>All the data on this USB stick will be lost.</p></div>
## To download only
If you don't need install or upgrade instructions, you can directly download
......
......@@ -148,16 +148,16 @@
<div class="dvd">[[<div class="btn btn-primary inline-block">Next: Burning Tails on a DVD</div>|dvd]]</div>
<div class="vm">[[<div class="btn btn-primary inline-block">Next: Virtualization</div>|doc/advanced_topics/virtualization]]</div>
<ul class="download-only-img">
<p>Upgrade your Tails USB stick and keep your persistent storage:</p>
<ul>
<li>[[Upgrade inside Tails|upgrade/tails]]</li>
</ul>
<p>Install a new USB stick:</p>
<ul>
<li>[[Install from Windows|install/win/usb]]</li>
<li>[[Install from macOS|install/mac/usb]]</li>
<li>[[Install from Linux|install/linux/usb]]</li>
</ul>
<p>Upgrade your Tails USB stick and keep your persistent storage:</p>
<ul>
<li>[[Upgrade inside Tails|upgrade/tails]]</li>
</ul>
</ul>
<ul class="download-only-iso">
<li>[[Burn on a DVD|dvd]]</li>
......@@ -273,16 +273,16 @@
<div class="dvd">[[<div class="btn btn-primary inline-block">Next: Burning Tails on a DVD</div>|dvd]]</div>
<div class="vm">[[<div class="btn btn-primary inline-block">Next: Virtualization</div>|doc/advanced_topics/virtualization]]</div>
<ul class="download-only-img">
<p>Upgrade your Tails USB stick and keep your persistent storage:</p>
<ul>
<li>[[Upgrade inside Tails|upgrade/tails]]</li>
</ul>
<p>Install a new USB stick:</p>
<ul>
<li>[[Install from Windows|install/win/usb]]</li>
<li>[[Install from macOS|install/mac/usb]]</li>
<li>[[Install from Linux|install/linux/usb]]</li>
</ul>
<p>Upgrade your Tails USB stick and keep your persistent storage:</p>
<ul>
<li>[[Upgrade inside Tails|upgrade/tails]]</li>
</ul>
</ul>
<ul class="download-only-iso">
<li>[[Burn on a DVD|dvd]]</li>
......
......@@ -105,6 +105,14 @@ See the list of [[long-standing issues|support/known_issues]].
# Get Tails 3.13
## To upgrade your Tails USB stick and keep your persistent storage
- [[Automatic upgrades|doc/first_steps/upgrade]] are available from 3.11,
3.12~rc1, 3.12, and 3.12.1 to 3.13.
- If you cannot do an automatic upgrade or if Tails fails to start after an
automatic upgrade, please try to do a [[manual upgrade|upgrade]].
## To install Tails on a new USB stick
Follow our installation instructions:
......@@ -115,14 +123,6 @@ Follow our installation instructions:
<div class="caution"><p>All the data on this USB stick will be lost.</p></div>
## To upgrade your Tails USB stick and keep your persistent storage
- [[Automatic upgrades|doc/first_steps/upgrade]] are available from 3.11,
3.12~rc1, 3.12, and 3.12.1 to 3.13.
- If you cannot do an automatic upgrade or if Tails fails to start after an
automatic upgrade, please try to do a [[manual upgrade|upgrade]].
## To download only
If you don't need install or upgrade instructions, you can directly download
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment