Commit 129de5e2 authored by sajolida's avatar sajolida
Browse files

Move requirements for Debian and Ubuntu version to the beginning of the scenario (#11017)

It's not nice to tell people they cannot finish a scenario after they started it.

We could even move this information in the /install/os but this would:

  - Require more design and implementation.
  - Might be harder to make as visible and information without polluting this
    page for everybody else.

Anyway, in a couple of months, Debian Wheezy will be unsupported officially and
Trusty will be superseded by a new LTS so we don't need a super fancy long-term
solution.
parent 13db4b6d
......@@ -13,6 +13,8 @@
<p class="start">Start in Debian or Ubuntu.</p>
[[!inline pages="install/inc/steps/debian_requirements.inline" raw="yes"]]
[[!inline pages="install/inc/steps/download.inline" raw="yes"]]
[[!inline pages="install/inc/steps/install_tails_installer.inline" raw="yes"]]
......
......@@ -6,6 +6,8 @@
<p>Start in Debian or Ubuntu.</p>
[[!inline pages="install/inc/steps/debian_requirements.inline" raw="yes"]]
Verify the Tails signing key
============================
......
<span class="application">Tails Installer</span> is available in:
- Debian 8 (Jessie) or later in the backports repository
- Ubuntu 15.10 (Wily) or later in a PPA (*Personal Package Archive*)
<div class="tip debian">
<p>To know your version of Debian or Ubuntu, open
<span class="application">System Settings</span> and click on
<span class="guilabel">Details</span>. For Debian, refer to the
<span class="guilabel">Base system</span> information.</p>
</div>
<div class="tip expert">
<p>To know your version of Ubuntu, execute
<span class="command">lsb_release -a</span>.</p>
</div>
<div class="tip">
<p>If it is impossible to install <span class="application">Tails
Installer</span> in your version of Ubuntu or Debian, you can [[install Tails using
<span class="application">GNOME Disks</span>|install/linux/usb/overview]]
instead. But it is more complicated and requires two USB sticks instead of
one.</span></p>
</div>
......@@ -3,33 +3,3 @@ Install <span class="application">Tails Installer</span>
In this step, you will install <span class="application">Tails
Installer</span>, a program designed specifically for installing Tails.
<span class="application">Tails Installer</span> is available in:
- Debian 8 (Jessie) or later in the backports repository
- Ubuntu 15.10 (Wily) or later in a PPA (*Personal Package Archive*)
<div class="tip debian">
<p>To know your version of Debian or Ubuntu, open
<span class="application">System Settings</span> and click on
<span class="guilabel">Details</span>. For Debian, refer to the
<span class="guilabel">Base system</span> information.</p>
</div>
<div class="tip expert">
<p>To know your version of Ubuntu, execute
<span class="command">lsb_release -a</span>.</p>
</div>
<div class="tip">
<p>If it is impossible to install <span class="application">Tails
Installer</span> in your version of Ubuntu or Debian, you can [[install Tails using
<span class="application">GNOME Disks</span>|install/linux/usb/overview]]
instead. But it is more complicated and requires two USB sticks instead of
one.</span></p>
</div>
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment