Commit f35d560b authored by Raphaël Hertzog's avatar Raphaël Hertzog
Browse files

Fix binary_debian-installer step to use linux-image-* metapackages instead of...

Fix binary_debian-installer step to use linux-image-* metapackages instead of linux-image-2.6-* which are gone.
parent f2225a80
live-build (3.0.5-1kali2) kali; urgency=medium
* Fix binary_debian-installer step to use linux-image-* metapackages
instead of linux-image-2.6-* which are gone.
-- Raphaël Hertzog <hertzog@debian.org> Sat, 21 Dec 2013 13:55:44 +0100
live-build (3.0.5-1kali1) kali; urgency=low
* Ensure xfsprogs and jfsutils are available in the ISO. Otherwise users
......
Description: Fix kernel meta-packages required for d-i
The linux-image-2.6-* meta-packages were transitional and are gone
in the latest version used by Kali.
.
Instead use the linux-image-* meta-packages.
Author: Raphaël Hertzog <hertzog@debian.org>
--- a/scripts/build/binary_debian-installer
+++ b/scripts/build/binary_debian-installer
@@ -353,7 +353,7 @@ then
;;
*)
- DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-2.6-amd64"
+ DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-amd64"
;;
esac
;;
@@ -381,7 +381,7 @@ then
;;
*)
- DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-2.6-486 linux-image-2.6-686"
+ DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-486 linux-image-686-pae"
;;
esac
;;
@@ -394,7 +394,7 @@ then
;;
*)
- DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-2.6-sparc64 linux-image-2.6-sparc64-smp"
+ DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-sparc64 linux-image-sparc64-smp"
;;
esac
;;
@@ -407,7 +407,7 @@ then
;;
*)
- DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-2.6-powerpc linux-image-2.6-powerpc64 linux-image-2.6-powerpc-smp"
+ DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-powerpc linux-image-powerpc64 linux-image-powerpc-smp"
;;
esac
;;
add-xfsprogs-jfsutils-to-d-i.patch
fix-kernel-metapackages-used-in-di-step.patch
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment