Commit b4d85ef5 authored by Raphaël Hertzog's avatar Raphaël Hertzog
Browse files

Update d-i setup code to use linux-image-586 instead of linux-image-486 for newer versions of Kali.

parent 0b0ff39d
live-build (4.0.4-1kali4) kali-dev; urgency=medium
* Update d-i setup code to use linux-image-586 instead of linux-image-486
for newer versions of Kali.
-- Raphaël Hertzog <hertzog@debian.org> Thu, 18 Jun 2015 10:42:53 +0200
live-build (4.0.4-1kali3) kali-dev; urgency=medium
* Fix EFI patch to properly include syslinux "libraries" which
......
From: =?utf-8?q?Rapha=C3=ABl_Hertzog?= <hertzog@debian.org>
Date: Thu, 18 Jun 2015 10:38:42 +0200
Subject: Use linux-image-586 instead of linux-image-486 for kali 2
---
scripts/build/installer_debian-installer | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/scripts/build/installer_debian-installer b/scripts/build/installer_debian-installer
index 5f6b3ca..1f137eb 100755
--- a/scripts/build/installer_debian-installer
+++ b/scripts/build/installer_debian-installer
@@ -369,7 +369,14 @@ then
;;
*)
- DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-486 linux-image-686-pae"
+ case "${LB_DISTRIBUTION}" in
+ kali-dev|kali-rolling|kali-next|sana)
+ DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-586 linux-image-686-pae"
+ ;;
+ *)
+ DI_PACKAGES="${DI_REQ_PACKAGES} linux-image-486 linux-image-686-pae"
+ ;;
+ esac
;;
esac
;;
......@@ -2,3 +2,4 @@ Add-support-for-EFI-boot-with-syslinux-efi.patch
Skip-comments-in-package-lists.patch
Drop-the-ixp4xx-flavour-on-armel-as-Kali-does-not-ha.patch
Better-handle-empty-package-lists.patch
Use-linux-image-586-instead-of-linux-image-486-for-k.patch
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment