1. 15 Jun, 2020 2 commits
  2. 06 Jun, 2020 4 commits
    • Zen Fu's avatar
      [weblate] Fix version detection in update dep script (tails#17377) · 88bc27cd
      Zen Fu authored
      We need to account for longer version strings than the one provided by
      the Pypi JSON for some packages.
      
      In the case at hand, Pypi will return "2.1" for latest user-agents
      version, but we should be looking for "2.1.0" in GitHub tags.
      88bc27cd
    • Zen Fu's avatar
      [weblate] Pin version of user-agents (tails#17377) · 185076c8
      Zen Fu authored
      The version in the Pypi JSON is "2.1" but there's no such tag in the
      repo and our dep update script does not currently account for such
      differences.
      185076c8
    • Zen Fu's avatar
      [weblate] Pin version of openpyxl (tails#17377) · 99abeace
      Zen Fu authored
      The deps update script does not correctly check for compatibility with
      Python for direct dependencies of Weblate (such check is only done for
      dependencies of dependencies).
      
      Therefore, we manually pin openpyxl version to <3.0 as bigger versions
      all depend on Python >= 3.6 which is not available in Debian Stretch.
      99abeace
    • Zen Fu's avatar
      [weblate] Do not serve the deps update script (tails#17377) · 606dbc55
      Zen Fu authored
      In its previous location, the dependencies update script was being
      served in the Puppet file server, but we don't need that, as such script
      is meant to be executed in the admin machine to generate Puppet code.
      606dbc55
  3. 03 Jun, 2020 4 commits