Commit d32b4160 authored by Zen Fu's avatar Zen Fu
Browse files

[weblate] Declare constraint for Python six

For some reason, our script is not detecting some dependency constraints
correctly, so i'm pinning this one manually.

From: https://github.com/django-compressor/django-compressor/blob/2.4/setup.py#L148
parent 294685c6
...@@ -26,7 +26,6 @@ class tails::weblate::debian_packages () { ...@@ -26,7 +26,6 @@ class tails::weblate::debian_packages () {
'python3-requests', 'python3-requests',
'python3-requests-oauthlib', 'python3-requests-oauthlib',
'python3-ruamel.yaml', 'python3-ruamel.yaml',
'python3-six',
'python3-sqlparse', 'python3-sqlparse',
'python3-tz', 'python3-tz',
'python3-whoosh', 'python3-whoosh',
......
...@@ -60,7 +60,7 @@ class tails::weblate::python_modules () { ...@@ -60,7 +60,7 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'django-compressor': tails::pip_package_from_repo { 'django-compressor':
version => '2.4', # >=2.1.1 version => '2.4', # >=2.1.1
url => 'https://github.com/django-compressor/django-compressor', url => 'https://github.com/django-compressor/django-compressor',
require => [Exec['pip_install_django-appconf'], Exec['pip_install_rjsmin']], require => [Exec['pip_install_django-appconf'], Exec['pip_install_rjsmin'], Exec['pip_install_six']],
} }
tails::pip_package_from_repo { 'django-crispy-forms': tails::pip_package_from_repo { 'django-crispy-forms':
...@@ -139,16 +139,21 @@ class tails::weblate::python_modules () { ...@@ -139,16 +139,21 @@ class tails::weblate::python_modules () {
url => 'https://github.com/WeblateOrg/siphashc', url => 'https://github.com/WeblateOrg/siphashc',
} }
tails::pip_package_from_repo { 'six':
version => '1.15.0', # >=1.11.0,>=1.7.0
url => 'https://github.com/benjaminp/six',
}
tails::pip_package_from_repo { 'social-auth-app-django': tails::pip_package_from_repo { 'social-auth-app-django':
version => '3.4.0', # >=3.1.0 version => '3.4.0', # >=3.1.0
url => 'https://github.com/python-social-auth/social-app-django', url => 'https://github.com/python-social-auth/social-app-django',
require => [Exec['pip_install_social-auth-core']], require => [Exec['pip_install_six'], Exec['pip_install_social-auth-core']],
} }
tails::pip_package_from_repo { 'social-auth-core': tails::pip_package_from_repo { 'social-auth-core':
version => '3.3.3', # >=3.1.0 version => '3.3.3', # >=3.1.0
url => 'https://github.com/python-social-auth/social-core', url => 'https://github.com/python-social-auth/social-core',
require => [Exec['pip_install_oauthlib'], Exec['pip_install_python3-openid']], require => [Exec['pip_install_oauthlib'], Exec['pip_install_six'], Exec['pip_install_python3-openid']],
} }
tails::pip_package_from_repo { 'translate-toolkit': tails::pip_package_from_repo { 'translate-toolkit':
......
...@@ -48,6 +48,8 @@ pip: ...@@ -48,6 +48,8 @@ pip:
- <3.0 # Bigger versions require Python >=3.6 - <3.0 # Bigger versions require Python >=3.6
rjsmin: rjsmin:
url: https://github.com/ndparker/rjsmin url: https://github.com/ndparker/rjsmin
six:
additional_condition: [ '>=1.12.0' ] # for django-compressor
translate-toolkit: translate-toolkit:
url: https://github.com/translate/translate url: https://github.com/translate/translate
translation-finder: translation-finder:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment