Commit a79afcb6 authored by Zen Fu's avatar Zen Fu
Browse files

[weblate] Update dependencies for Weblate 3.5.1 (tails#17377)

This is what I ran:

  python3 files/weblate/external_scripts/update_puppet_dependecy_files.py \
    --weblate-version 3.5.1 \
    --debian-suite stretch \
    --weblate-repo ~/weblate/
parent 73d3bd58
# Manage Weblate dependencies that are in Debian
#
# **WARNING**
# This file was generated automatically, do not manually modify it.
#
class tails::weblate::debian_packages () {
# some packages are commented out because the needed versions for Weblate
# 3.5.1 are still not available in Debian stable. Fore more details, see:
# https://redmine.tails.boum.org/code/issues/10038
$packages = [
'ccze',
'ipython3', # for more convenient debugging
'ccze', 'ipython3', # for more convenient debugging
'mercurial', # so we can use pip to install from hg repos
# Dependencies for Weblate 3.5.1
'python3-chardet',
'python3-cryptography',
'python3-dateutil',
'python3-defusedxml',
'python3-diff-match-patch',
'python3-jwt',
'python3-levenshtein',
'python3-lxml',
'python3-memcache',
'python3-mysqldb',
'python3-openid',
'python3-pil',
'python3-psycopg2',
'python3-pyuca',
'python3-rcssmin',
'python3-requests',
'python3-requests-oauthlib',
'python3-ruamel.yaml',
'python3-six',
'python3-sqlparse',
'python3-tblib',
'python3-tz',
'python3-whoosh',
'python3-yaml',
......
# Manage Weblate dependencies that are in not in Debian
#
# **WARNING**
# This file was generated automatically, do not manually modify it.
#
class tails::weblate::python_modules () {
$pip_packages = [
......@@ -8,55 +12,50 @@ class tails::weblate::python_modules () {
ensure_packages($pip_packages)
# The following deps are in Debian Stretch but with a version that is older
# than needed by Weblate 3.5.1. The versions noted as comments are the
# requirements for the current Weblate version we are running (check
# manifests/weblate.pp to know which version it is).
# Dependencies for Weblate 3.5.1
tails::pip_package_from_repo { 'amqp':
version => '2.5.2', # >=2.5.2,<2.6
version => '2.6.0', # <2.7,>=2.6.0
url => 'http://github.com/celery/py-amqp',
require => 'Exec[pip_install_vine]',
}
tails::pip_package_from_repo { 'asgiref':
version => '3.2.3', # ~=3.2
version => '3.2.7', # ~=3.2
url => 'http://github.com/django/asgiref/',
}
tails::pip_package_from_repo { 'billiard':
version => '3.6.1.0', # <4.0,>=3.6.1
tag => '3.6.1',
version => '3.6.3.0', # <4.0,>=3.6.3.0
url => 'https://github.com/celery/billiard',
}
tails::pip_package_from_repo { 'celery':
version => '4.4.0', # >=4.0
tag => 'v4.4.0',
version => '4.4.4', # >=4.0
tag => 'v4.4.4',
url => 'https://github.com/celery/celery',
require => 'Exec[pip_install_billiard]',
require => 'Exec[pip_install_kombu]',
require => 'Exec[pip_install_vine]',
require => 'Exec[pip_install_couchbase-cffi]',
require => 'Exec[pip_install_redis]',
}
tails::pip_package_from_repo { 'celery-batches':
version => '0.2', # >= 0.2
tag => 'v0.2',
version => '0.3', # >=0.2
tag => 'v0.3',
url => 'https://github.com/percipient/celery-batches',
require => 'Exec[pip_install_celery]',
}
tails::pip_package_from_repo { 'django':
version => '1.11.27', # >=1.11,<2.0
version => '1.11.29', # <2.0,>=1.11
url => 'https://github.com/django/django',
require => 'Exec[pip_install_asgiref]',
}
tails::pip_package_from_repo { 'django-appconf':
version => '1.0.3', # >= 1.0
tag => 'v1.0.3',
version => '1.0.4', # >=1.0
tag => 'v1.0.4',
url => 'https://github.com/django-compressor/django-appconf',
require => 'Exec[pip_install_django]',
}
......@@ -69,7 +68,7 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'django-crispy-forms':
version => '1.8.1', # >=1.6.1
version => '1.9.1', # >=1.6.1
url => 'https://github.com/django-crispy-forms/django-crispy-forms',
}
......@@ -81,35 +80,30 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'filelock':
version => '3.0.12', # >=3.0.1
tag => 'v3.0.12',
tag => 'v3.0.12',
url => 'https://github.com/benediktschmitt/py-filelock',
}
tails::pip_package_from_repo { 'importlib-metadata':
version => '1.3.0', # >=0.18
version => '1.6.1', # >=0.18
url => 'https://gitlab.com/python-devs/importlib_metadata',
require => 'Exec[pip_install_zipp]',
}
tails::pip_package_from_repo { 'jellyfish':
version => '0.7.2', # >= 0.6.1
version => '0.8.2', # >=0.6.1
url => 'https://github.com/jamesturk/jellyfish',
}
tails::pip_package_from_repo { 'kombu':
version => '4.6.7', # <4.7,>=4.6.7
version => '4.6.10', # <4.7,>=4.6.10
tag => 'v4.6.10',
url => 'http://github.com/celery/kombu',
require => 'Exec[pip_install_amqp]',
require => 'Exec[pip_install_importlib-metadata]',
require => 'Exec[pip_install_redis]',
}
tails::pip_package_from_repo { 'more-itertools':
version => '8.0.2',
tag => 'v8.0.2',
url => 'https://github.com/erikrose/more-itertools',
}
tails::pip_package_from_repo { 'oauthlib':
version => '3.1.0', # >=3.0.0
tag => 'v3.1.0',
......@@ -117,13 +111,19 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'openpyxl':
version => '3.0.2', # >=2.5.0
version => '3.0.3', # >=2.5.0
url => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
repo_type => 'hg',
}
tails::pip_package_from_repo { 'python3-openid':
version => '3.1.0', # >=3.0.10
tag => 'v3.1.0',
url => 'http://github.com/necaris/python3-openid',
}
tails::pip_package_from_repo { 'redis':
version => '3.3.11', # >= 3.3.11 -- from celery's kombu
version => '3.5.3', # >=3.2.0
url => 'https://github.com/andymccurdy/redis-py',
}
......@@ -134,38 +134,40 @@ class tails::weblate::python_modules () {
tails::pip_package_from_repo { 'siphashc':
version => '1.3', # >=0.8
tag => 'v1.3',
tag => 'v1.3',
url => 'https://github.com/WeblateOrg/siphashc',
}
tails::pip_package_from_repo { 'social-auth-app-django':
version => '3.1.0', # >=3.1.0
version => '3.4.0', # >=3.1.0
url => 'https://github.com/python-social-auth/social-app-django',
require => 'Exec[pip_install_social-auth-core]',
}
tails::pip_package_from_repo { 'social-auth-core':
version => '3.2.0', # >=3.1.0
version => '3.3.3', # >=3.1.0
url => 'https://github.com/python-social-auth/social-core',
require => 'Exec[pip_install_oauthlib]',
require => 'Exec[pip_install_python3-openid]',
}
tails::pip_package_from_repo { 'translate-toolkit':
version => '2.4.0', # >=2.3.1
version => '2.5.1', # >=2.3.1
url => 'https://github.com/translate/translate',
}
tails::pip_package_from_repo { 'translation-finder':
version => '1.7', # >=1.0
version => '2.1', # >=1.0
url => 'https://github.com/WeblateOrg/translation-finder.git',
}
tails::pip_package_from_repo { 'ua-parser':
version => '0.8.0', # >=0.8.0
version => '0.10.0', # >=0.9.0
url => 'https://github.com/ua-parser/uap-python',
}
tails::pip_package_from_repo { 'user-agents':
version => '2.0', # >=1.1.0
tag => 'v2.0',
version => '2.1', # >=1.1.0
url => 'https://github.com/selwin/python-user-agents',
require => 'Exec[pip_install_ua-parser]',
}
......@@ -177,10 +179,9 @@ class tails::weblate::python_modules () {
}
tails::pip_package_from_repo { 'zipp':
version => '0.6.0', # >=0.5
tag => 'v0.6.0',
version => '3.1.0', # >=0.5
tag => 'v3.1.0',
url => 'https://github.com/jaraco/zipp',
require => 'Exec[pip_install_more-itertools]',
}
}
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment