override.yaml 2.05 KB
Newer Older
1
2
3
4
5
6
7
---
skip:
  - pillow   # Pillow is packaged as python3-pil in Debian
  - brotli   # extra depdendecies by kombu, we don't need
  - brotlipy # extra depdendecies by kombu, we don't need
  - configparser # it is part of PYthon 3.5
  - setuptools   # we need this anyway to install packages via pip
8
9
10
  - backports.lzma # only needed for python <3.3
  - importlib-resources # depdendency only needed for testing importlib-metadata
  - contextlib2 # only needed for python <3
11
12
13
14
15
16
17
require_pip:
  - django
  - django-appconf
  - django-crispy-forms
  - django-compressor
  - jellyfish
  - translate-toolkit
18
19
extra_pip:
  - cheroot  # optional dependency of "translate-toolkit" for the tmserver backend
20
21
22
23
24
25
26
require_debian:
  - python3-levenshtein # optional Weblate dependency to speed up DB migrations
  - python3-memcache
  - python3-mysqldb     # Tails uses MariaDB as Weblate database
  - python3-pil         # Pillow is packaged as python3-pil in Debian
  - python3-pyuca       # optional Weblate depdendency for Unicode support
  - python3-yaml        # For our own scripts
27
28
29
30
pip:
  celery:
    url: https://github.com/celery/celery
  django:
Sandro Knauß's avatar
Sandro Knauß committed
31
32
    additional_condition:
      - <2.0
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
    url: https://github.com/django/django
  django-appconf:
    url: https://github.com/django-compressor/django-appconf
  django-compressor:
    url: https://github.com/django-compressor/django-compressor
  djangorestframework:
    url: https://github.com/encode/django-rest-framework
  importlib-metadata:
    url: https://gitlab.com/python-devs/importlib_metadata
  jellyfish:
    url: https://github.com/jamesturk/jellyfish
  kombu:
    url: http://github.com/celery/kombu
  openpyxl:
    url: https://bitbucket.org/openpyxl/openpyxl/src/default
    repo_type: hg
49
50
    additional_condition:
      - <3.0  # Bigger versions require Python >=3.6
51
52
  rjsmin:
    url: https://github.com/ndparker/rjsmin
53
54
  six:
    additional_condition: [ '>=1.12.0' ]  # for django-compressor
55
56
57
58
  translate-toolkit:
    url: https://github.com/translate/translate
  translation-finder:
    url: https://github.com/WeblateOrg/translation-finder.git